Opened 2 years ago

Closed 4 months ago

#85 closed user support (migrated)

Possible bug when using equality constraints

Reported by: gabrielenava Owned by: ferreau
Priority: normal Milestone:
Component: Matlab interface Version: 3.2.0
Keywords: Cc:

Description

Hi all, I think I may have found a bug inside the qpOASES algorithm when performing a constrained optimization with equality constraints in MATLAB. In particular, I considered the following optimization problem:

min |u|2

s.t. Au = 0

where u is a [29 * 1] vector and A is a [6 * 29] matrix with rank 6. In theory, this problem is well posed and the solution is u = 0. However, for some valid constraint matrices A qpOASES cannot find a solution, and returns the following error:

ERROR:  Division by zero
->ERROR:  Abnormal termination due to TQ factorisation
  ->ERROR:  Determination of step direction failed
    ->ERROR:  Abnormal termination due to TQ factorisation
      ->ERROR:  Initialisation failed! QP could not be solved!

Attached to this script there is a matlab code with an example. The constraint matrix is stored in a .mat file (attached to the issue, too). Also, relaxing the problem with inequality constraints of the form:

min |u|2

s.t. -eps < Au < eps,

eps > 0

did not solve the issue. As an additional information, I noted that in case the problem is really unfeasible the error from qpOASES is different.

May you help me in understanding this issue? Thanks in advance.

Attachments (1)

testQPOASES.zip (1.6 KB) - added by gabrielenava 2 years ago.

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by gabrielenava

comment:1 Changed 4 months ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: https://github.com/coin-or/qpOASES/issues/85

Note: See TracTickets for help on using tickets.