Opened 3 years ago

Closed 4 months ago

#71 closed user support (migrated)

qpOASES in Siumlink cannot solve QP Problem

Reported by: Michel Owned by: ferreau
Priority: high Milestone:
Component: Simulink interface Version: 3.2.1
Keywords: Simulink, Matlab Cc:

Description

I try to solve an optimization problem using the simulink interface. Before I've already used the matlab interface. Here, it's possible to solve the problem. The inputs are attached. For solving I used:

[x,fval,exiflag,iter,lamda,ausOutput]=qpOASES(H,g,A,lb,ub,lbA,ubA)

Then I built up the problem inputs in the same way given in the examples. The inputs are attached, too. I'm using the example_QProblem.mdl.
However, by solving in simulink the following errors occur: Division by zero, Abnormal termination due to Cholesky factorisation, Determination of step direction failed, Initialisation failed! QP could not be solved,...
Any clue what's wrong in my problem statement? Why can it be solved in matlab but not in simulink?
Regards Michel

Change History (1)

comment:1 Changed 4 months ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: https://github.com/coin-or/qpOASES/issues/71

Note: See TracTickets for help on using tickets.