Opened 2 years ago

Closed 2 years ago

#57 closed installation issue (duplicate)

Problem installing qpOASES3.2.0 on windows

Reported by: zlahard Owned by: ferreau
Priority: high Milestone:
Component: C++ core Version: 3.2.0
Keywords: Cc:

Description

Hello!

I've been trying to install qpOASES-3.2.0 on windows, without any luck.
I have tried nmake from visual studio, but it gives me the following error:

make.mk(32) : fatal error U1000: syntax error: ')' missing in macro invocation
Stop.

I saw in an earlier ticked that you suggested to add "MAKE=NMAKE" in the makefile. I tried this, but I still get the same result.

I also tried downloading minGW and using minGW32-make, but that instead results in this error message:

process_begin: CreateProcess?(NULL, getconf, LONG_BIT, ...) failed.
The system cannot find the path specified.
Makefile:43: recipe for target 'src' failed
mingw32-make; *[src] Error 1

Line 43 in makefile contains the following:

@cd $@; ${MAKE} -s

Any input on this? I appreciate all help.

Change History (4)

comment:1 Changed 2 years ago by ferreau

  • Status changed from new to assigned

comment:2 Changed 2 years ago by ferreau

  • Resolution set to wontFix
  • Status changed from assigned to closed

This issue has already been reported in tickets #36 and #53, the same answers apply here.

comment:3 Changed 2 years ago by ferreau

  • Resolution wontFix deleted
  • Status changed from closed to reopened

comment:4 Changed 2 years ago by ferreau

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.