Opened 4 years ago

Closed 4 years ago

#36 closed installation issue (wontFix)

make files in windows w/ visual studio & MiniGW

Reported by: starremi Owned by: ferreau
Priority: normal Milestone:
Component: C++ core Version: 3.1.0
Keywords: Cc:

Description

Hello,

I'd like to give this tool a shot on Windows.

I followed the instructions in the manual but it will not make. It is reaching "make_windows.mk" but fails there. Seems like it must be something simple, but I've only ever used solutions with Visual Studio. This is my first time running make.

Developer Command Prompt for VS2013: (I called nmake)
makefile(42) : fatal error U1001: syntax error : illegal character '{' in macro
Stop.

MiniGW:
user@PCNAME /c/temp/qpOASES-3.1.0
$ make
c:/temp/qpOASES-3.1.0/src/LAPACKReplacement.cpp:35:29: fatal error: qpOASES/Util
s.hpp: No such file or directory

#include <qpOASES/Utils.hpp>


compilation terminated.
make[1]: * c/temp/qpOASES-3.1.0/src//LAPACKReplacement.o Error 1
make:
* [src] Error 2

user@PCNAME /c/temp/qpOASES-3.1.0
$

Change History (3)

comment:1 Changed 4 years ago by ferreau

  • Status changed from new to assigned
  • Version changed from 3.0.1 to 3.1.0

comment:2 Changed 4 years ago by ferreau

Could you provide us with more details to reproduce your problem(s). In particular, i) exact operating system, ii) compiler version, iii) the workflow you are following.

It looks like you tried two different approaches. When calling nmake, the error in line 42 looks like the variable MAKE is undefined. Try adding the

MAKE=NMAKE

at the beginning of the main Makefile in the project root folder.

As for the second approach (using MinGW/MiniGW?): if it cannot find the file Utils.hpp, there is surely some include directive -I missing. Possibly, the TOP variable in make.mk has not been evaluated correctly by your build system, so the IDIR variable (and others) got messed up.

comment:3 Changed 4 years ago by ferreau

  • Resolution set to wontFix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.