Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#26 closed installation issue (fixed)

Undefined symbols (OSX10.10)

Reported by: manuel.schaich Owned by: ckirches
Priority: normal Milestone: Release 3.1
Component: C++ core Version: 3.0.0
Keywords: Cc:

Description

The linking of libqpOASES.dylib always fails for undefined symbols. See attachment.

Using cc (clang-600.0.54) to compile on osx 10.10.

Attachments (1)

support.txt (18.5 KB) - added by manuel.schaich 5 years ago.
Terminal output of make.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by manuel.schaich

Terminal output of make.

comment:1 Changed 5 years ago by ferreau

  • Milestone set to Release 3.0
  • Owner changed from ferreau to ckirches

comment:2 Changed 5 years ago by ferreau

  • Milestone changed from Release 3.0 to Release 3.1

Thanks a lot for supporting, we will have a look at it.

comment:3 Changed 4 years ago by ferreau

Can you try to explicitly link the stdc++ library when compiling qpOASES? This helped me getting rid of undefined reference: vtable for __cxxabiv1::__class_type_info errors in a different context.

I also fixed most of the compiler warnings in the meantim.

Last edited 4 years ago by ferreau (previous) (diff)

comment:4 Changed 4 years ago by ferreau

  • Milestone changed from Release 3.1 to Release 3.2

Ticket retargeted after milestone closed

comment:5 Changed 4 years ago by ferreau

  • Resolution set to fixed
  • Status changed from new to closed

Release 3.1 has been successfully tested under OSX Yosemite and the clang compiler. I am going to close this ticket, please let us know if there is still an issue related to qpOASES.

comment:6 Changed 4 years ago by ferreau

  • Milestone changed from Release 3.2 to Release 3.1
Note: See TracTickets for help on using tickets.