Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1 closed defect (fixed)

Smi does not compile with gcc 4.3

Reported by: stefan Owned by: kingaj
Priority: minor Milestone:
Component: component1 Version:
Keywords: Cc:

Description

Hi,

gcc 4.3 complains about some extra ';', an unknown INT_MAX, and about something that should be included from cstring. Attached is a patch to correct this. It should work with the latest release and latest stable, and be easily adaptable to trunk.

Stefan

Attachments (1)

smi.patch_for_gcc4_3 (3.8 KB) - added by stefan 14 years ago.
corrections to have smi compiling with gcc 4.3

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by stefan

corrections to have smi compiling with gcc 4.3

comment:1 Changed 14 years ago by kingaj

  • Owner changed from somebody to kingaj
  • Status changed from new to assigned

comment:2 Changed 14 years ago by kingaj

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 in reply to: ↑ description Changed 14 years ago by kingaj

Replying to stefan:

Hi Stefan

I made changes to trunk -- looks fine. Will also apply to stable 0.81 and release. Thanks.

Alan

Hi,

gcc 4.3 complains about some extra ';', an unknown INT_MAX, and about something that should be included from cstring. Attached is a patch to correct this. It should work with the latest release and latest stable, and be easily adaptable to trunk.

Stefan

Note: See TracTickets for help on using tickets.