Opened 5 months ago

Closed 4 months ago

#314 closed defect (fixed)

Error while building IPOPT in Mac OS 10.14.2

Reported by: mrajase Owned by: ipopt-team
Priority: normal Component: Ipopt
Version: 3.12 Severity: normal
Keywords: Cc:

Description

I am trying to install IPOPT in Mac OS 10.14.2. I was able to successfully configure script, but I am failing the IPOPT build with errors.

I successfully ran the configuration of IPOPT with the following command:

../configure CC=gcc CXX=g++

I tried setting other flags, but only the above configuration worked. Then I followed the instructions given in the IPOPT Compiling & Installation guide to make

make

It exited with an error, whose output is attached (output_make.out).

Also, the "config.log" file is attached for information about the setup environment.

Since I am very new to Mac OS and IPOPT, I appreciate any help with this error and for your time.

Thanks, Murali

Attachments (2)

config.log (52.1 KB) - added by mrajase 5 months ago.
config.log
output_make.txt (6.7 KB) - added by mrajase 5 months ago.
output of make

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by mrajase

config.log

Changed 5 months ago by mrajase

output of make

comment:1 Changed 5 months ago by stefan

gcc/g++ seem to be picked up from XCode (/Applications/Xcode.app/Contents/Developer/usr), but ranlib and ar from some installation of miniconda (/Users/Murali/miniconda2/envs/dpasgp/bin/x86_64-apple-darwin13.4.0-ranlib). Probably these are not compatible.

comment:2 Changed 4 months ago by mrajase

Thank you stefan for the comment it really helped me target the issue.

I checked the redundancies and it seems that I had tried to build IPOPT while in an activated conda environment. I was able to manage building IPOPT by exiting the conda environment.

Thank you so much!

comment:3 Changed 4 months ago by stefan

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.