Ignore:
Timestamp:
Oct 11, 2013 10:44:41 AM (7 years ago)
Author:
bradbell
Message:

get_eigen.sh: Attempt to get new version of eigen to build on jenkins master.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/bin/get_eigen.sh

    r2914 r2922  
    6161prefix=`pwd`'/build/prefix'
    6262# -----------------------------------------------------------------------------
     63# determine which version of cmake to use
     64cmake --version |  sed \
     65                -e 's|[^0-9.]*||g' \
     66                -e 's|\([0-9]*\)\.\([0-9]*\)\..*|\1 * 10 + \2|' \
     67        | bc > get_sacado.$$
     68cmake_version=`cat get_sacado.$$`
     69rm get_sacado.$$
     70echo "cmake_version=$cmake_version"
     71#
     72cmake_program=''
     73if [ "$cmake_version" -ge '28' ]
     74then
     75        cmake_program='cmake'
     76else
     77        for cmake_version in 28 29
     78        do
     79                if which cmake$cmake_version >& /dev/null
     80                then
     81                        cmake_program="cmake$cmake_version"
     82                fi
     83        done
     84fi
     85if [ "$cmake_program" == '' ]
     86then
     87        echo 'cannot find a verison of cmake that is 2.8 or higher'
     88        exit 1
     89fi
     90# -----------------------------------------------------------------------------
    6391if [ ! -d build/external ]
    6492then
Note: See TracChangeset for help on using the changeset viewer.