Opened 10 years ago

Closed 10 years ago

#3 closed defect (fixed)

"make" gives an error

Reported by: Hai1982 Owned by: pbelotti
Priority: major Milestone:
Component: component1 Version:
Keywords: Cc:

Description

Hello!

I try to install Couenne and have followed the instructions. When I get to the "make" instruction (in the build-directory), I get the following error message:

../../../ThirdParty/Mumps?/MUMPS/src/dmumps_part2.F:4761.72:

USE TOOLS_COMMON

1

Fatal Error: Can't open module file 'tools_common.mod' for reading at (1): No such file or directory make[1]: * [dmumps_part2.lo] Fehler 1 make[1]: Verlasse Verzeichnis '/home/sonja/Couenne/build/ThirdParty/Mumps' make: * [all-recursive] Fehler 1

Looking into the folder, I found the file tools_coomon_mod.F which seemed to be the one he searched, so I named it tools_common.mod, which produces the following error message:

../../../ThirdParty/Mumps?/MUMPS/src/dmumps_part2.F:4761.72:

USE TOOLS_COMMON

1

Fatal Error: File 'tools_common.mod' opened at (1) is not a GFORTRAN module file make[1]: * [dmumps_part2.lo] Fehler 1 make[1]: Verlasse Verzeichnis '/home/sonja/Couenne/build/ThirdParty/Mumps' make: * [all-recursive] Fehler 1

Could you please help me? Thank you!

Change History (5)

comment:1 Changed 10 years ago by pbelotti

Hi,

I'll try to reproduce the error. Did you download the stable/0.3 version or some of the releases (0.3.0 or 0.2.2)? Also, I assume you are using MUMPS instead of HSL, right?

Thanks, Pietro

comment:2 Changed 10 years ago by Hai1982

Well, I installed the stable/0.2 as I just copied out of the installation guide. I am going to try with the 0.3 version, but at the moment I do not get onto the HSL Arcive Server.

It points I should include a dummy file for METIS in the ma57ad.f, but METIS is not yet part of the ThirdParty? Folder. Do I have to install it?

Thanks for helping!

comment:3 Changed 10 years ago by pbelotti

The INSTALL.HSL does suggest adding a dummy file, but Metis is not used in Couenne and thus you should ignore that.

I have recently noticed an error similar to what you get in your original posting. In my case, it was due to an obsolete version of mc19ad.f. The version that gave an error was from 1974, while the version I have, which works, is from 1977. Can you check that and, if so, replace it with the "recent" version?

If that also fails, please let me know (as an alternative to HSL, you could use Mumps).

Cheers, Pietro

comment:4 Changed 10 years ago by pbelotti

  • Owner changed from somebody to pbelotti
  • Status changed from new to assigned

Dear submitter,

did you solve this problem? Please let me know if you need further help on this. I am going to close this ticket soon unless this still doesn't work.

Best, Pietro

comment:5 Changed 10 years ago by pbelotti

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.