source: trunk/coopr/pysp/__init__.py @ 1761

Last change on this file since 1761 was 1761, checked in by wehart, 11 years ago

Moving the plugin imports to the end of the package init.py files.
My work with PyUtilib? has highlighted the fact that putting these
first causes an error.

File size: 1.0 KB
Line 
1#  _________________________________________________________________________
2#
3#  Coopr: A COmmon Optimization Python Repository
4#  Copyright (c) 2008 Sandia Corporation.
5#  This software is distributed under the BSD License.
6#  Under the terms of Contract DE-AC04-94AL85000 with Sandia Corporation,
7#  the U.S. Government retains certain rights in this software.
8#  For more information, see the Coopr README.txt file.
9#  _________________________________________________________________________
10
11import pyutilib.plugin
12
13pyutilib.plugin.PluginGlobals.push_env( "coopr.pysp" )
14
15from scenariotree import *
16from convergence import *
17from ph import *
18from phextension import *
19from phutils import *
20from ef import *
21from ef_writer_script import *
22from ph_script import *
23
24pyutilib.plugin.PluginGlobals.pop_env()
25
26
27try:
28    import pkg_resources
29    #
30    # Load modules associated with Plugins that are defined in
31    # EGG files.
32    #
33    for entrypoint in pkg_resources.iter_entry_points('coopr.pysp'):
34        plugin_class = entrypoint.load()
35except:
36    pass
37
Note: See TracBrowser for help on using the repository browser.