Opened 2 years ago

Closed 7 weeks ago

#80 closed defect (migrated)

Infeasible solution returned when problem is unbounded

Reported by: blegat Owned by: somebody
Priority: major Milestone:
Component: component1 Version:
Keywords: Cc:

Description

Dear Clp maintainers,

When trying to solve the following problem

Maximize x1

Subject To

x1 >= 1

Bounds

x1 free
x2 <= -1

End

Clp detects unboundedness and reports a correct unbounded ray but returns an infeasible solution (i.e. [0, 0]).

Can we expect Clp to return a feasible solution when the problem is unbounded ? We are currently wondering whether this is a reasonable expectation for LP solver here.

Change History (2)

comment:1 Changed 2 years ago by blegat

I asked the same question for Gurobi (here: https://groups.google.com/forum/#!topic/gurobi/cKZY6huEBZo) and they replied that the solver stops as soon as it finds an unbounded ray and therefore has no guarantee on the feasibility of the problem. This is also explained here: https://www.gurobi.com/documentation/7.0/refman/optimization_status_codes.html Therefore, to obtain a feasible solution, one needs to set the objective to 0 and reoptimize. Is it the same for Clp ?

comment:2 Changed 7 weeks ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: ​https://github.com/coin-or/Clp/issues/80

Note: See TracTickets for help on using tickets.