Opened 8 years ago

Closed 8 months ago

#54 closed defect (migrated)

HotStart problem with stable/1.14

Reported by: fmargot Owned by: somebody
Priority: major Milestone:
Component: component1 Version:
Keywords: Cc: fmargot@…

Description

The attached code reads an LP file, initialSolve(), markHotStart(), change both bounds of variable 11 to 3, solveFromHotStart(), change both bounds of variable 11 to 2, solveFromHotStart().

When printing the status of the optimization, when bounds are 3, the problem is not solved to optimality and iterationLimit is reached, which is quite odd for such a small problem. If the input file is modified, setting the lower bound of var 11 to 3 in the lp file, the three problems are solved to optimality (they all have an optimal value of 49).

It also seems that getIterationCount() always returns 0 when using solveFromHotstart().

Attachments (3)

clp_hotstart.cpp (3.2 KB) - added by fmargot 8 years ago.
hotstart.lp (1.7 KB) - added by fmargot 8 years ago.
output.txt (885 bytes) - added by fmargot 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by fmargot

Changed 8 years ago by fmargot

Changed 8 years ago by fmargot

comment:1 Changed 8 months ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: ​https://github.com/coin-or/Clp/issues/54

Note: See TracTickets for help on using tickets.