Opened 9 years ago

Closed 7 months ago

#38 closed defect (migrated)

BuildTools 32bit lib on 64bit system

Reported by: davide10 Owned by: somebody
Priority: major Milestone:
Component: component1 Version: 1.0
Keywords: 32bit 64bit lib configure make Cc:

Description

Hi everybody,

we are trying to compile clp solver on a 64 bit linux system. as our main programm is 32 bit we need the resulting clp shared library to be 32 bit also.

unfortunatly we do not understand how to use the configure script to do the trick. we used configure in the following manner:

configure --host="i386-redhat-linux" --build="i386-redhat-linux" ADD_CFLAGS="-m32" ADD_CXXFLAGS="-m32" ADD_FFFLAGS="-m32".

i seems that although we used the m32 compiler option the configure script is still tyring to link in some external 64 bit librarys as our system is 64 bit.

The solution proposed for our ticket #37 to change the CC and CXX did not solve the problem.

Kind regards David

Change History (2)

comment:1 Changed 9 years ago by ladanyi

I have tested this on a 64-bit ubuntu machine and everything worked like a charm. Please, try this. If it does not work then add a comment, and attach the complete output of the compilation process.

Downloaded cpl-1.11.1. Configured with: ../configure CC="gcc -m32" CXX="g++ -m32" F77="gfortran -m32" Ran "make" and "make install". The info on the resulting libs/executables is:

ladanyi@daniel:~/COIN/Clp/1.11.1/build$ file lib/* lib/libClp.la: libtool library file lib/libClp.so: symbolic link to `libClp.so.0.0.0' lib/libClp.so.0: symbolic link to `libClp.so.0.0.0' lib/libClp.so.0.0.0: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped lib/libCoinUtils.la: libtool library file lib/libCoinUtils.so: symbolic link to `libCoinUtils.so.0.0.0' lib/libCoinUtils.so.0: symbolic link to `libCoinUtils.so.0.0.0' lib/libCoinUtils.so.0.0.0: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

ladanyi@daniel:~/COIN/Clp/1.11.1/build$ file bin/* bin/clp: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped ladanyi@daniel:~/COIN/Clp/1.11.1/build$ ldd bin/*

linux-gate.so.1 => (0xf7f27000) libClp.so.0 => /home/ladanyi/COIN/Clp/1.11.1/build/lib/libClp.so.0 (0xf7db0000) libCoinUtils.so.0 => /home/ladanyi/COIN/Clp/1.11.1/build/lib/libCoinUtils.so.0 (0xf7c8a000) libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7b7e000) libm.so.6 => /lib32/libm.so.6 (0xf7b58000) libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7b49000) libc.so.6 => /lib32/libc.so.6 (0xf79e6000) /lib/ld-linux.so.2 (0xf7f28000)

comment:2 Changed 7 months ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: ​https://github.com/coin-or/Clp/issues/38

Note: See TracTickets for help on using tickets.