Opened 9 years ago

Closed 9 years ago

#37 closed defect (invalid)

Support 32bit on 64bit system

Reported by: davide10 Owned by: somebody
Priority: major Milestone:
Component: component1 Version: 1.0
Keywords: 32bit 64bit CLP Cc:

Description

Hello,

i want to include the CLP Solver in a project. All my other shared_libs are 32bit. But i run everything on 64bit machines. When I try to configure and make CLP it always creates 64 libs. I already tried additional input commands (Host, Build, ADD_FLAGS) when running configure but nothing changed. What are the required input parameters to create 32bit libs on 64bit machines.

Kind regards David

Change History (1)

comment:1 Changed 9 years ago by ladanyi

  • Resolution set to invalid
  • Status changed from new to closed

In general, the page https://projects.coin-or.org/BuildTools/wiki/user-configure#CommandLineArgumentsforconfigure should give you lots of information.

It would be useful to know what platform you are working on :-). I will assume it's linux.

Unfortunately there does not appear to be a variable for adding flags to the link command :-( (this should be a ticket against BuildTools?). You can get around this by specifying the compiler appropriately which in turn will get used to link as well. Specifying CC="gcc -m32" CXX="-g++ -m32" F77="gfortran -m32" (or g77/g95, whichever compiler you use) should solve your problem.

Note: See TracTickets for help on using tickets.