Opened 13 years ago

Closed 12 years ago

#10 closed defect (worksforme)

ClpCholesky

Reported by: penders Owned by: somebody
Priority: minor Milestone:
Component: component1 Version:
Keywords: Cc:

Description

If I define "#define WSSMP_BARRIER 1" as below I get the following error :"...undefined reference to `ClpCholeskyWssmp::ClpCholeskyWssmp?(int)'collect2: ld returned 1 exit status make: * [clp_solver] Error 1". When I skip the #define it will compile and solve, but using the Dense method.

I have issues figuring it out, would anybody have a suggestion or an example where this works?

In a post in March there was a suggestion to use "ClpCholeskyUfl?.hpp" but I also did not get that to work.

Any help would be appreciated.

The version of CLP I am using is Cgl-0.5.1 (hope this is what you were asking for)

Thanks,

Paul

p.s. I have attached the makefile as well as the little toy code that does not work

Attachments (2)

clp_solver.cpp (1.4 KB) - added by penders 13 years ago.
makefile (756 bytes) - added by penders 13 years ago.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by penders

Changed 13 years ago by penders

comment:1 Changed 12 years ago by ladanyi

Hello,

I'm trying to clean up the old Clp tickets. Could you check that the ticket you submitted (#10) is still valid against the latest stable version (stable/1.5)?

Thanks, --Laci

comment:2 Changed 12 years ago by penders

Did not get the latest stable version, switched to CPLEX and uninstalled from machine so I am sorry I cannot help you.

Thanks,

Paul

comment:3 Changed 12 years ago by ladanyi

  • Resolution set to worksforme
  • Status changed from new to closed

For WSSMP a license is needed, for UFL I can't reproduce the problem with the latest stable, and the submitter is not using clp any longer :-(...

--Laci

Note: See TracTickets for help on using tickets.