Opened 13 years ago

Closed 11 years ago

#1 closed defect (fixed)

Clp refuses to configure on 64 Linux machine

Reported by: johntomlin Owned by: somebody
Priority: major Milestone:
Component: component1 Version:
Keywords: Clp configure Cc:

Description

I downloaded and uncompressed the tarball for CLP of Sept 1. However, it refuses to configure: as follows:[tomlin@ps5 Clp]$ ./configure -C configure: creating cache config.cache checking for egrep... grep -E checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking whether directory CoinUtils? is available... yes checking whether directory Data/Netlib? is available... yes checking whether directory Data/Sample? is available... yes checking whether directory Clp is available... yes updating cache config.cache configure: creating ./config.status config.status: creating Makefile configure: configuring in CoinUtils? configure: running /bin/sh './configure' --prefix=/home/tomlin/Clp '-C' --cache-file=../config.cache --srcdir=. configure: loading cache ../config.cache checking build system type... x86_64-unknown-linux-gnu checking whether we want to compile in debug mode... no checking for xlc... no checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed configure: C compiler options are: -O3 -fomit-frame-pointer -pipe -DNDEBUG -pedantic-errors -Wimplicit -Wparentheses -Wseq uence-point -Wreturn-type -Wcast-qual -Wall checking for xlC... no checking for aCC... no checking for CC... no checking for g++... g++ checking whether we are using the GNU C++ compiler... yes checking whether g++ accepts -g... yes configure: C++ compiler options are: -O3 -fomit-frame-pointer -pipe -DNDEBUG -pedantic-errors -Wimplicit -Wparentheses -Wr eturn-type -Wcast-qual -Wall -Wpointer-arith -Wwrite-strings -Wconversion checking for egrep... (cached) grep -E checking for a BSD-compatible install... (cached) /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... (cached) gawk checking whether make sets $(MAKE)... (cached) yes checking for style of include used by make... GNU checking for dlfcn.h... yes checking host system type... x86_64-unknown-linux-gnu checking for a sed that does not truncate output... /bin/sed checking for ld used by gcc... /usr/bin/ld checking if the linker (/usr/bin/ld) is GNU ld... yes checking for /usr/bin/ld option to reload object files... -r checking for BSD-compatible nm... /usr/bin/nm -B checking whether ln -s works... yes checking how to recognise dependent libraries... pass_all checking how to run the C preprocessor... gcc -E checking for ANSI C header files... no checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for dlfcn.h... (cached) yes checking how to run the C++ preprocessor... g++ -E checking for g77... g77 checking whether we are using the GNU Fortran 77 compiler... yes checking whether g77 accepts -g... yes checking the maximum length of command line arguments... 32768 checking command to parse /usr/bin/nm -B output from gcc object... ok checking for objdir... .libs checking for ar... ar checking for ranlib... ranlib checking for strip... strip checking if gcc supports -fno-rtti -fno-exceptions... yes checking for gcc option to produce PIC... -fPIC checking if gcc PIC flag -fPIC works... yes checking if gcc static flag -static works... yes checking if gcc supports -c -o file.o... yes checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking whether -lc should be explicitly linked in... no checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no configure: creating libtool appending configuration tag "CXX" to libtool checking for ld used by g++... /usr/bin/ld -m elf_x86_64 checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking for g++ option to produce PIC... -fPIC checking if g++ PIC flag -fPIC works... yes checking if g++ static flag -static works... yes checking if g++ supports -c -o file.o... yes checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate appending configuration tag "F77" to libtool checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no checking for g77 option to produce PIC... -fPIC checking if g77 PIC flag -fPIC works... yes checking if g77 static flag -static works... yes checking if g77 supports -c -o file.o... yes checking whether the g77 linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate checking dependency style of gcc... gcc3 checking dependency style of g++... gcc3 checking whether to enable maintainer-specific portions of Makefiles... no checking for cmath... yes checking for cfloat... yes checking for cieeefp... no checking for ieeefp.h... no checking whether finite is declared... yes checking whether isnan is declared... yes checking for COIN project CoinUtils?... . checking if user provides library for Gmpl... no updating cache ../config.cache configure: creating ./config.status config.status: creating Makefile config.status: creating src/Makefile config.status: creating test/Makefile config.status: creating coinutils_addlibs.txt config.status: creating inc/config_coinutils.h config.status: executing depfiles commands configure: creating libtool appending configuration tag "CXX" to libtool checking for ld used by g++... /usr/bin/ld -m elf_x86_64 checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking for g++ option to produce PIC... -fPIC checking if g++ PIC flag -fPIC works... yes checking if g++ static flag -static works... yes checking if g++ supports -c -o file.o... yes checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate appending configuration tag "F77" to libtool checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no checking for g77 option to produce PIC... -fPIC checking if g77 PIC flag -fPIC works... yes checking if g77 static flag -static works... yes checking if g77 supports -c -o file.o... yes checking whether the g77 linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate checking dependency style of gcc... gcc3 checking dependency style of g++... gcc3 checking whether to enable maintainer-specific portions of Makefiles... no checking for cmath... yes checking for cfloat... yes checking for cieeefp... no checking for ieeefp.h... no checking whether finite is declared... yes checking whether isnan is declared... yes checking for COIN project CoinUtils?... . checking if user provides library for Gmpl... no updating cache ../config.cache configure: creating ./config.status config.status: creating Makefile config.status: creating src/Makefile config.status: creating test/Makefile config.status: creating coinutils_addlibs.txt config.status: creating inc/config_coinutils.h config.status: executing depfiles commands configure: Configuration of CoinUtils? successful configure: configuring in Data/Netlib? configure: running /bin/sh './configure' --prefix=/home/tomlin/Clp '-C' --cache-file=../../config.cache --srcdir=. chmod: changing permissions of `conf32100.sh' (requested: 0775, actual: 0664): Operation not permitted configure: loading cache ../../config.cache checking for egrep... (cached) grep -E checking for a BSD-compatible install... (cached) /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... (cached) gawk checking whether make sets $(MAKE)... (cached) yes checking whether to enable maintainer-specific portions of Makefiles... no checking for style of include used by make... GNU checking for gcc... (cached) gcc checking for C compiler default output file name... a.out checking whether the C compiler works... configure: error: cannot run C compiled programs. If you meant to cross compile, use `--host'. See `config.log' for more details. configure: error: /bin/sh './configure' failed for Data/Netlib?

The details of the machine are given here:

[tomlin@ps5 Clp]$ uname -a Linux ps5.labs.corp.yahoo.com 2.4.21-32.0.1.EL_SFS2.0_2smp #1 SMP Fri Dec 16 14:17:44 PST 2005 x86_64 x86_64 x86_64 GNU/Li nux [tomlin@ps5 Clp]$ uname -s Linux [tomlin@ps5 Clp]$ uname -n ps5.labs.corp.yahoo.com [tomlin@ps5 Clp]$ uname -r 2.4.21-32.0.1.EL_SFS2.0_2smp [tomlin@ps5 Clp]$ uname -s Linux [tomlin@ps5 Clp]$ uname -v #1 SMP Fri Dec 16 14:17:44 PST 2005 [tomlin@ps5 Clp]$ uname -m x86_64 [tomlin@ps5 Clp]$ uname -p x86_64 [tomlin@ps5 Clp]$ uname -i x86_64 [tomlin@ps5 Clp]$ uname -o GNU/Linux

The entire config.log file isavaiable on request (I dont see how to attach it here).

Attachments (3)

config.log (5.5 KB) - added by johntomlin 13 years ago.
config.output (7.5 KB) - added by johntomlin 13 years ago.
uname.data (955 bytes) - added by johntomlin 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by johntomlin

Changed 13 years ago by johntomlin

Changed 13 years ago by johntomlin

comment:1 Changed 13 years ago by johntomlin

I managed to attach the files in readable form. As stated in my first attempt, the problem is failure of Clp to configure on a 64-bit Linux machine (details given in uname.data file).

comment:3 follow-up: Changed 12 years ago by ladanyi

Hello,

I'm trying to clean up the old Clp tickets. Could you check that the ticket you submitted (#1) is still valid against the latest stable version (stable/1.5)?

Thanks, --Laci

comment:4 in reply to: ↑ 3 Changed 12 years ago by stefan

Hi,

I frequently build Clp on 64bit machines and did not get any problems.

Stefan

comment:5 Changed 11 years ago by forrest

  • Resolution set to fixed
  • Status changed from new to closed

apparently fixed

Note: See TracTickets for help on using tickets.