Changeset 2262


Ignore:
Timestamp:
Apr 18, 2017 12:02:20 PM (3 years ago)
Author:
stefan
Message:

allow to build with ThirdParty/Mumps? <= 1.5 and 1.6, and user provided Mumps

  • include mumps_mpi.h if ThirdParty/Mumps? >= 1.6 (should define COIN_USE_MUMPS_MPI_H)
  • otherwise include mpi.h
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/Clp/src/ClpCholeskyMumps.cpp

    r2249 r2262  
    1515extern "C" {
    1616#include "dmumps_c.h"
     17// In newer ThirdParty/Mumps, mpi.h is renamed to mumps_mpi.h.
     18// We get informed about this by having COIN_USE_MUMPS_MPI_H defined.
     19#ifdef COIN_USE_MUMPS_MPI_H
    1720#include "mumps_mpi.h"
     21#else
     22#include "mpi.h"
     23#endif
    1824}
    1925
Note: See TracChangeset for help on using the changeset viewer.