Changeset 1751 for trunk


Ignore:
Timestamp:
Jun 19, 2011 10:49:54 AM (8 years ago)
Author:
stefan
Message:

no check for coinglpk version number for now

Location:
trunk/Clp
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/Clp/configure

    r1750 r1751  
    2379923799
    2380023800if test -n "$PKG_CONFIG" ; then
    23801   if $PKG_CONFIG --exists "coinglpk >= 4.39"; then
    23802     GLPK_VERSIONS="`$PKG_CONFIG --modversion "coinglpk >= 4.39" 2>/dev/null | sed -n -e "1h;2,\\$H;\\${g;s/\n/ /g;p}"`"
    23803      cflags=`$PKG_CONFIG --cflags "coinglpk >= 4.39" 2>/dev/null`
     23801  if $PKG_CONFIG --exists "coinglpk"; then
     23802    GLPK_VERSIONS="`$PKG_CONFIG --modversion "coinglpk" 2>/dev/null | sed -n -e "1h;2,\\$H;\\${g;s/\n/ /g;p}"`"
     23803     cflags=`$PKG_CONFIG --cflags "coinglpk" 2>/dev/null`
    2380423804    # pkg-config cannot handle spaces, so CYGPATH_W cannot be put into .pc files
    2380523805        # thus, we modify the cflags extracted from pkg-config by putting CYGPATH_W behind -I's
     
    2381023810    fi
    2381123811    GLPK_CFLAGS="$cflags"
    23812     GLPK_LIBS=`$PKG_CONFIG --libs "coinglpk >= 4.39" 2>/dev/null`
    23813     GLPK_DATA=`$PKG_CONFIG --variable=datadir "coinglpk >= 4.39" 2>/dev/null`
     23812    GLPK_LIBS=`$PKG_CONFIG --libs "coinglpk" 2>/dev/null`
     23813    GLPK_DATA=`$PKG_CONFIG --variable=datadir "coinglpk" 2>/dev/null`
    2381423814     coin_has_glpk=yes
    2381523815        echo "$as_me:$LINENO: result: yes: $GLPK_VERSIONS" >&5
     
    2382223822          GLPK_LIBS=`echo " $GLPK_LIBS " | sed -e 's/ \(\/[^ ]*\/\)\([^ ]*\)\.lib / \`$(CYGPATH_W) \1 | sed -e "s|\\\\\\\\\\\\\\\\\\\\|\/|g"\`\2.lib /g'`
    2382323823        fi
    23824         GLPK_PCREQUIRES="coinglpk >= 4.39"
     23824        GLPK_PCREQUIRES="coinglpk"
    2382523825
    2382623826        # augment X_PCREQUIRES, X_CFLAGS, and X_LIBS for each build target X in ClpLib
    2382723827
    23828           CLPLIB_PCREQUIRES="coinglpk >= 4.39 $CLPLIB_PCREQUIRES"
     23828          CLPLIB_PCREQUIRES="coinglpk $CLPLIB_PCREQUIRES"
    2382923829          CLPLIB_CFLAGS="$GLPK_CFLAGS $CLPLIB_CFLAGS"
    2383023830          CLPLIB_LIBS="$GLPK_LIBS $CLPLIB_LIBS"
     
    2383323833
    2383423834  else
    23835     GLPK_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "coinglpk >= 4.39"`
     23835    GLPK_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "coinglpk"`
    2383623836      coin_has_glpk=notGiven
    2383723837        echo "$as_me:$LINENO: result: not given: $GLPK_PKG_ERRORS" >&5
     
    2386923869GLPK_PCREQUIRES=
    2387023870
    23871 # initial list of dependencies is "coinglpk >= 4.39", but we need to filter out version number specifications (= x, <= x, >= x, != x)
    23872 projtoprocess="coinglpk "
     23871# initial list of dependencies is "coinglpk", but we need to filter out version number specifications (= x, <= x, >= x, != x)
     23872projtoprocess="coinglpk"
    2387323873
    2387423874# we first expand the list of projects to process by adding all dependencies just behind the project which depends on it
     
    2407124071  fi
    2407224072
    24073   GLPK_PCREQUIRES="coinglpk >= 4.39"
    24074 
    24075     CLPLIB_PCREQUIRES="coinglpk >= 4.39 $CLPLIB_PCREQUIRES"
     24073  GLPK_PCREQUIRES="coinglpk"
     24074
     24075    CLPLIB_PCREQUIRES="coinglpk $CLPLIB_PCREQUIRES"
    2407624076    CLPLIB_CFLAGS="$GLPK_CFLAGS $CLPLIB_CFLAGS"
    2407724077    CLPLIB_LIBS="$GLPK_LIBS $CLPLIB_LIBS"
  • trunk/Clp/configure.ac

    r1734 r1751  
    8383# Glpk also brings AMD
    8484if test $coin_has_cholmod = false -a $coin_has_amd = false ; then
    85   AC_COIN_CHECK_PACKAGE(Glpk, [coinglpk >= 4.39], [ClpLib])
     85  AC_COIN_CHECK_PACKAGE(Glpk, [coinglpk], [ClpLib])
    8686  if test $coin_has_glpk = yes ; then
    8787    AC_MSG_NOTICE([using AMD from GLPK package])
Note: See TracChangeset for help on using the changeset viewer.