Ignore:
Timestamp:
Mar 9, 2011 5:56:48 AM (9 years ago)
Author:
stefan
Message:

install ClpCholeskyXyz?.hpp for advanced users

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/Clp/src/Makefile.am

    r1693 r1701  
    154154        ClpCholeskyBase.hpp \
    155155        ClpCholeskyDense.hpp \
    156         ClpCholeskyWssmp.hpp \
    157156        ClpConstraint.hpp \
    158157        ClpConstraintLinear.hpp \
     
    194193        Idiot.hpp
    195194
     195
     196# if AMD, CHOLMOD, or GLPK is available, then install ClpCholeskyUfl.hpp (for advanced users)
     197if COIN_HAS_AMD
     198includecoin_HEADERS += ClpCholeskyUfl.hpp
     199else
     200if COIN_HAS_CHOLMOD
     201includecoin_HEADERS += ClpCholeskyUfl.hpp
     202else
     203if COIN_HAS_GLPK
     204includecoin_HEADERS += ClpCholeskyUfl.hpp
     205endif
     206endif
     207endif
     208
     209if COIN_HAS_MUMPS
     210includecoin_HEADERS += ClpCholeskyMumps.hpp
     211endif
     212
     213if COIN_HAS_WSMP
     214includecoin_HEADERS += ClpCholeskyWssmp.hpp ClpCholeskyWssmpKKT.hpp
     215endif
     216
    196217# needed by Cbc
    197218includecoin_HEADERS += CbcOrClpParam.cpp
Note: See TracChangeset for help on using the changeset viewer.