Opened 11 years ago

Closed 11 years ago

#70 closed defect (worksforme)

Cbc, reproducible segmentation fault

Reported by: nowozin Owned by: somebody
Priority: major Component: component1
Version: Keywords:
Cc:

Description

A MILP problem discussed at http://forums.ilog.com/optimization/index.php/topic,1045.0.html consistently crashes Cbc as follows:

$ /opt/coin-cbc-trunk20090317/bin/cbc sol21.lp 
Coin Cbc and Clp Solver version 1.2trunk, build Mar 17 2009
command line - /opt/coin-cbc-trunk20090317/bin/cbc sol21.lp (default strategy 1)
Continuous objective value is 2.95918 - 0.06 seconds
Cgl0003I 0 fixed, 1 tightened bounds, 0 strengthened rows, 0 substitutions
Cgl0004I processed model has 179 rows, 1422 columns (1422 integer) and 7588 elements
Objective coefficients multiple of 1
Cutoff increment increased from 1e-05 to 0.999
Cbc0045I 1 integer variables out of 1422 objects (1422 integer) have cost of 1 - high priority
Cbc0045I branch on satisfied Y create fake objective Y random cost N
Cbc0038I Pass   1: suminf.   10.20918 (54) obj. 13 iterations 374
Cbc0038I Pass   2: suminf.    3.57143 (31) obj. 27 iterations 206
Cbc0038I Pass   3: suminf.    4.40476 (31) obj. 27 iterations 27
Cbc0038I Pass   4: suminf.    4.19048 (30) obj. 27 iterations 87
Cbc0038I Pass   5: suminf.    4.14286 (30) obj. 27 iterations 7
Cbc0038I Pass   6: suminf.    4.09524 (31) obj. 27 iterations 47
Cbc0038I Pass   7: suminf.    4.45238 (32) obj. 47.8333 iterations 33
Cbc0038I Pass   8: suminf.    4.35714 (33) obj. 47.8333 iterations 146
Cbc0038I Pass   9: suminf.    4.30952 (32) obj. 56.8333 iterations 8
Cbc0038I Pass  10: suminf.    4.30952 (32) obj. 56.8333 iterations 77
Cbc0038I Pass  11: suminf.    4.64286 (32) obj. 58.5 iterations 15
Cbc0038I Pass  12: suminf.    4.64286 (32) obj. 58.5 iterations 89
Cbc0038I Pass  13: suminf.    4.30952 (32) obj. 56.8333 iterations 8
Cbc0038I Pass  14: suminf.    9.65967 (52) obj. 100001 iterations 206
Cbc0038I Pass  15: suminf.    3.32857 (26) obj. 100116 iterations 122
Cbc0038I Pass  16: suminf.    2.92857 (25) obj. 100117 iterations 139
Cbc0038I Pass  17: suminf.    4.69048 (20) obj. 100083 iterations 85
Cbc0038I Pass  18: suminf.    4.19048 (21) obj. 100083 iterations 44
Cbc0038I Pass  19: suminf.    4.40476 (23) obj. 100104 iterations 52
Cbc0038I Pass  20: suminf.    4.40476 (23) obj. 100104 iterations 28
Cbc0038I Pass  21: suminf.    4.07143 (24) obj. 100102 iterations 6
Cbc0038I Pass  22: suminf.    3.40476 (23) obj. 100103 iterations 47
Cbc0038I Pass  23: suminf.    5.26190 (22) obj. 100127 iterations 36
Cbc0038I Pass  24: suminf.    4.83333 (23) obj. 100127 iterations 66
Cbc0038I Pass  25: suminf.    3.26190 (23) obj. 100103 iterations 44
Cbc0038I Pass  26: suminf.    3.19048 (23) obj. 100103 iterations 139
Cbc0038I Pass  27: suminf.    5.42857 (22) obj. 100127 iterations 70
Cbc0038I Pass  28: suminf.    5.14202 (30) obj. 100048 iterations 300
Cbc0038I Pass  29: suminf.    3.38095 (26) obj. 100048 iterations 99
Cbc0038I Pass  30: suminf.    2.71429 (24) obj. 100048 iterations 119
Cbc0038I No solution found this major pass
Cbc0038I Before mini branch and bound, 1172 integers at bound fixed and 0 continuous
Cbc0038I Full problem 179 rows 1422 columns, reduced to 179 rows 249 columns - too large
Cbc0038I Mini branch and bound did not improve solution (0.33 seconds)
Cbc0038I After 0.33 seconds - Feasibility pump exiting - took 0.33 seconds
Cbc0031I 616 added rows had average density of 11.0763
Cbc0013I At root node, 616 cuts changed objective from 2.95918 to 5.53236 in 57 passes
Cbc0014I Cut generator 0 (Probing) - 1629 row cuts, 0 column cuts (616 active)  in 1.512 seconds - new frequency is 1
Cbc0014I Cut generator 1 (Gomory) - 116 row cuts, 0 column cuts (0 active)  in 6.084 seconds - new frequency is -100
Cbc0014I Cut generator 2 (Knapsack) - 1761 row cuts, 0 column cuts (0 active)  in 0.204 seconds - new frequency is 1
Cbc0014I Cut generator 3 (Clique) - 0 row cuts, 0 column cuts (0 active)  in 0.224 seconds - new frequency is -100
Cbc0014I Cut generator 4 (MixedIntegerRounding2) - 151 row cuts, 0 column cuts (0 active)  in 0.156 seconds - new frequency is -100
Cbc0014I Cut generator 5 (FlowCover) - 0 row cuts, 0 column cuts (0 active)  in 0.084 seconds - new frequency is -100
Cbc0014I Cut generator 6 (TwoMirCuts) - 159 row cuts, 0 column cuts (0 active)  in 0.168 seconds - new frequency is -100
Cbc0010I After 0 nodes, 1 on tree, 1e+50 best solution, best possible 6 (12.96 seconds)
Segmentation fault

The problem can be downloaded from http://www.icmc.usp.br/~alysson/files/share/sol21.lp I also attached the file to this issue.

Attachments (1)

sol21.lp (128.6 KB) - added by nowozin 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by nowozin

comment:1 Changed 11 years ago by forrest

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce either with -O3 or -g

Note: See TracTickets for help on using tickets.