Opened 4 years ago

Closed 4 years ago

#159 closed defect (fixed)

CBC 2.9.0 won't compile on OS X Yosemite

Reported by: GSnyder Owned by: tkr
Priority: trivial Component: Cbc
Version: trunk Keywords:
Cc:

Description

The problem is actually in CoinUtils?, in the new CoinRational?.cpp file. Clang doesn't recognize labs() because stdlib.h hasn't been included.

Change History (1)

comment:1 Changed 4 years ago by tkr

  • Resolution set to fixed
  • Status changed from new to closed

Sorry for missing this. I do actually build on OS X regularly, but this somehow did not get picked up. It is fixed in trunk and stable/2.10 of CoinUilts (and thus in trunk and stable/2.9 of Cbc). I will be making a 2.10.1 release and a 2.9.1 of CoinUtils in the next few days that will include this fix.

Note: See TracTickets for help on using tickets.