Opened 5 years ago

Closed 7 weeks ago

#147 closed defect (migrated)

Potential race hazard in cbc

Reported by: hmi21 Owned by: tkr
Priority: major Component: Cbc
Version: 2.8.8 Keywords:
Cc:

Description

Running cbc on the attached problem multiple times with threads set to the number of cores produces different results. All cuts, heuristics and preprocessing are turned off. Attached is a script which runs the problem repeatedly until it finds a discrepancy. Removing the threads option produces the same right answer when rerun. I've configured cbc using the --enable-cbc-parallel, --disable-shared and --enable-static flags. I've tried different versions of cbc (2.8 and 2.8.9) and the issue is reproducible with all of them. Tested on Ubuntu 12.04.

Attachments (2)

racehazard.mps (35.0 KB) - added by hmi21 5 years ago.
run_cbc.sh (437 bytes) - added by hmi21 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by hmi21

Changed 5 years ago by hmi21

comment:1 Changed 7 weeks ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

This ticket has been migrated to GitHub and will be resolved there: https://github.com/coin-or/Cbc/issues/147

Note: See TracTickets for help on using tickets.