Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#136 closed defect (invalid)

/usr/lib/libOsiClp.so.1

Reported by: rafaelvareto Owned by: tkr
Priority: major Component: Cbc
Version: 2.7 Keywords: libOsiClp
Cc:

Description

Everytime I try to run CBC I get the following error: cbc: symbol lookup error: /usr/lib/libOsiClp.so.1: undefined symbol: _ZTI15ClpPackedMatrix

What could be that?

Change History (2)

comment:1 Changed 6 years ago by tkr

  • Resolution set to invalid
  • Status changed from new to closed

How did you build and install COIN? This error means the symbol is not defined in the library when it should be. It could results from mixing 32-bit and 64-bit libraries, from some sort of corruption, or from a version mis-match. Do

nm /usr/lib/libOsiClp.so.1

and then grep for ClpPackedMatrix in the results. This should give you a start in figuring out what the problem is. I'm going to close this ticket, since it is not a bug report.

comment:2 Changed 6 years ago by rafaelvareto

I installed exactly this way: svn co https://projects.coin-or.org/svn/Cbc/releases/2.8.3 coin-Cbc cd coin-Cbc ./configure --prefix=/usr make sudo make install

I just did what you have told me to do, and I got the following files: vareto@Rafael-DELL:~/Downloads/Cbc?-2.8.3$ nm /usr/lib/libOsiClp.so.1 | grep "ClpPackedMatrix?"

U _ZN15ClpPackedMatrixC1ERK16CoinPackedMatrix U _ZTI15ClpPackedMatrix

Do you have any idea of what it could be?

Note: See TracTickets for help on using tickets.