Opened 9 years ago

Closed 8 years ago

#100 closed defect (fixed)

'Invalid Heap' error, MS VS debug builds

Reported by: jcheng@… Owned by: lou
Priority: major Component:
Version: trunk Keywords:
Cc:

Description

The cbcSolve was generated with Microsoft Visual C++ 9.0.

The run to solve MIPLIB 2003 pp08a.mps generated "invalid heap" message when it was executing

std::pop_heap(nodes_.begin(), nodes_.end(), comparison_);

in Cbctree.cpp (line 281).

Will any please help me.

Thanks.

Attachments (1)

pp08a.mps (27.0 KB) - added by jcheng@… 9 years ago.
MIPLIB 2003 pp08a.mps

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by jcheng@…

MIPLIB 2003 pp08a.mps

comment:1 Changed 9 years ago by lou

  • Owner set to lou
  • Priority changed from trivial to major
  • Status changed from new to assigned
  • Type changed from task to defect
  • Version set to trunk

Yep, known problem. Been around far too long, because none of us really like to develop on Windows. The root cause is incautious changes to the node evaluation function without rebuilding the heap, which causes a violation of the heap property (parent better than either child) which causes a failure in debug checks in the MS heap implementation, which produces the 'invalid heap' message. Have a look at trunk r1506. I wouldn't want to predict how long it'll take before this makes it out to a stable branch, but you can probably do a local merge. -- Lou --

comment:2 Changed 9 years ago by lou

  • Summary changed from Cbc 2.50 and MIPLIB 2003 pp08a.mps to 'Invalid Heap' error, MS VS debug builds

comment:3 Changed 8 years ago by lou

  • Resolution set to fixed
  • Status changed from assigned to closed

This fix has made it out at least as far as stable. I'm closing this ticket.

Note: See TracTickets for help on using tickets.