Changes between Version 10 and Version 11 of user-troubleshooting


Ignore:
Timestamp:
Feb 12, 2011 2:39:21 PM (9 years ago)
Author:
stefan
Comment:

svn version > 1.3.1 also works

Legend:

Unmodified
Added
Removed
Modified
  • user-troubleshooting

    v10 v11  
    1010=== Using the correct version of subversion ===
    1111
    12 If you want to use subversion from the command line (with the {{{svn}}} program), you need to '''make sure that you have a version of {{{svn}}} that is able to use the SSL layer''', i.e., that it is able to connect to {{{https://...}}} URLs.  You can find out if your version of {{{svn}}} supports this by typing {{{svn --version}}}.  If it says "{{{handles 'https' scheme}}}," you are fine.  Otherwise, you need to obtain a different version, or compile the {{{svn}}} executable yourself.  In that case, make sure you specify {{{--with-ssl}}} when you run {{{configure}}} for subversion.  For information on how to obtain subversion, click [wiki:user-download here]. ''Note: We are successfully using '''subversion version 1.3.1''' to download the code; older versions might not work properly.''
     12If you want to use subversion from the command line (with the {{{svn}}} program), you need to '''make sure that you have a version of {{{svn}}} that is able to use the SSL layer''', i.e., that it is able to connect to {{{https://...}}} URLs.  You can find out if your version of {{{svn}}} supports this by typing {{{svn --version}}}.  If it says "{{{handles 'https' scheme}}}," you are fine.  Otherwise, you need to obtain a different version, or compile the {{{svn}}} executable yourself.  In that case, make sure you specify {{{--with-ssl}}} when you run {{{configure}}} for subversion.  For information on how to obtain subversion, click [wiki:user-download here]. ''Note: We are successfully using '''subversion version 1.3.1 and higher''' to download the code; older versions might not work properly.''
    1313
    1414For most of the COIN-OR projects, we use the {{{externals}}} feature of subversion, which allows us to get the correct version for all dependencies for each project.  You might noticed that this slows the downloading down a bit; you just need to be patient ;)