Changes between Version 7 and Version 8 of current-issues


Ignore:
Timestamp:
Nov 19, 2006 12:24:58 AM (13 years ago)
Author:
lou
Comment:

Corrected a few typos.

Legend:

Unmodified
Added
Removed
Modified
  • current-issues

    v7 v8  
    33== Compilation ==
    44
    5  * '''On Cygwin, GNU make version 3.81-1 delivered by the default setup program doesn't work''' with the automatic header file dependencies, generated by the compilers.  The error message you will because of this bug will look something like this:
     5 * '''On Cygwin, GNU make version 3.81-1 delivered by the default setup program doesn't work''' with the automatic header file dependencies, generated by the compilers.  The error message you will see because of this bug will look something like this:
    66{{{
    77make[2]: Entering directory `/home/andreasw/COIN-svn/OBJgcc-debug/Clp/trunk/Clp/src'
     
    1717 * '''--omit-frame-pointer leads to failure of C++ throw''' for some GCC compiler versions. Suggested solutions:
    1818  1. If possible, upgrade to a GCC version which does not have this problem. GCC 4.1.1 is known to work correctly in many environments.
    19   1. Use the variables OPT_CXXFLAGS, OPT_CFLAGS, and OPT_FFLAGS to override the default optimisation options when executing {{{configure}}}. To determine the correct set of options, look for the string {{{omit-frame-pointer}}} in BuildTools/coin.m4. Currently (06.10.20), adding
     19  1. Use the variables OPT_CXXFLAGS, OPT_CFLAGS, and OPT_FFLAGS to override the default optimisation options when executing {{{configure}}}. To determine the correct set of options, look for the string {{{omit-frame-pointer}}} in !BuildTools/coin.m4. Currently (06.10.20), adding
    2020{{{
    2121OPT_CXXFLAGS="-O3" OPT_CFLAGS="-O3" OPT_FFLAGS="-O3"