Changes between Version 45 and Version 46 of current-issues


Ignore:
Timestamp:
Nov 19, 2013 5:11:31 AM (6 years ago)
Author:
stefan
Comment:

note on -Wl,--no-as-needed

Legend:

Unmodified
Added
Removed
Modified
  • current-issues

    v45 v46  
    6262== Compilation ==
    6363
     64 * If you get unresolved symbols like '''dlopen''' on '''Ubuntu''' even though '''{{{-ldl}}} is present''', then try again after rerunning configure with the option '''{{{LDFLAGS=-Wl,--no-as-needed}}}'''.
     65
    6466 * '''When building older versions of COIN on CYGWIN, GNU make version 3.81-1 delivered by the default setup program doesn't work''' with the automatic header file dependencies generated by the compilers.  The error message you will see because of this bug will look something like this:
    6567{{{
     
    6769.deps/ClpCholeskyBase.Plo:1: *** multiple target patterns.  Stop.
    6870}}}
    69 This is no longer the case with the most recent versions of the BuildTools, so the suggested solution is just to upgrade to a more recent version. If for some reason, you need to build an older version, the easiest workaround for this problem is to add
     71  This is no longer the case with the most recent versions of the !BuildTools, so the suggested solution is just to upgrade to a more recent version. If for some reason, you need to build an older version, the easiest workaround for this problem is to add
    7072{{{
    7173--disable-dependency-tracking
    7274}}}
    73 to your configure command.
     75  to your configure command.
    7476
    7577 * '''On AIX, with the xlC compiler''' the CXX flag -qrtti has been needed.