Changes between Version 33 and Version 34 of current-issues


Ignore:
Timestamp:
Feb 12, 2011 2:45:44 PM (9 years ago)
Author:
stefan
Comment:

updates

Legend:

Unmodified
Added
Removed
Modified
  • current-issues

    v33 v34  
    1111 * '''On OsX, care must be taken regarding Fortran compiler''', see [https://projects.coin-or.org/Bonmin/wiki/OsxInstall the Bonmin OsX install page].
    1212
    13  * On '''MacOS X''', if you use the Intel 10 compilers and build static (or debug) libraries, it is wise to set F77 to {{{"ifort -shared-intel"}}} to avoid later problems when COIN libraries are linked to each other.
     13 * On '''MacOS X''', if you use the Intel 10 compilers and build static (or debug) libraries, it is wise to set F77 to {{{"ifort -shared-intel"}}} to avoid later problems when COIN-OR libraries are linked to each other.
    1414
    1515 * On '''MacOS X 10.5''', you should use
     
    3030   }}}
    3131
    32  * '''Configure is unable to find the symbol {{{glp_lpx_simplex}}} when checking for the presence of glpk.''' Glpk has changed its naming convention for API routines. This is normally invisible to users of glpk (who always use {{{lpx_simplex}}} in code). Current COIN configuration tests understand this; the best solution is to upgrade.
     32 * '''Configure is unable to find the symbol {{{glp_lpx_simplex}}} when checking for the presence of glpk.''' Glpk has changed its naming convention for API routines. This is normally invisible to users of glpk (who always use {{{lpx_simplex}}} in code). Current COIN-OR configuration tests understand this; the best solution is to upgrade.
    3333
    3434 If that's not convenient, the workaround is to use the configuration flag {{{--disable-glpk-libcheck}}}. If you have the ability to regenerate configuration files, add a leading underscore ('_') to the symbol in relevant {{{configure.ac}}} files. For example,
     
    9191}}}
    9292
    93  * '''Ampl Solver Library crashes with new GNU compiler''' (e.g., version 4.4.1), it segfaults in la_replace, see Ipopt ticket https://projects.coin-or.org/Ipopt/ticket/118.  Solution is to use an older compiler.
     93 * '''Ampl Solver Library crashes with GNU compiler 4.4.1''', it segfaults in la_replace, see Ipopt ticket https://projects.coin-or.org/Ipopt/ticket/118.  Solution is to use an older or newer compiler.