Changes between Version 28 and Version 29 of current-issues


Ignore:
Timestamp:
Nov 2, 2009 11:12:17 PM (12 years ago)
Author:
kmartin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • current-issues

    v28 v29  
    2020
    2121 * On '''MacOS X 10.5''', if you get failures when running the code due to lazy symbol binding, try to rebuild everything with {{{LDFLAGS="-flat_namespace"}}}. However, this solution might fail too.
     22
     23* On '''MacOS X 10.6''', it is sufficient to
     24   {{{
     25     ADD_FFLAGS="-mmacosx-version-min=10.4"
     26   }}}
     27   Do not add  ADD_CXXFLAGS="-mmacosx-version-min=10.4" or you will have problems with try catch causing ABORT TRAP errors. If you are going to compile with ASL you also try to build static libs by adding 
     28   {{{
     29      --enable-static --disable-shared
     30   }}}
    2231
    2332 * '''Configure is unable to find the symbol {{{glp_lpx_simplex}}} when checking for the presence of glpk.''' Glpk has changed its naming convention for API routines. This is normally invisible to users of glpk (who always use {{{lpx_simplex}}} in code). Current COIN configuration tests understand this; the best solution is to upgrade.