Opened 8 years ago

Closed 8 years ago

#88 closed defect (fixed)

coin.m4 does not work on AIX native shell

Reported by: andreasw Owned by: stefan
Priority: major Component: build system
Version: 0.6 Keywords:
Cc:

Description

Hi,

I'm trying to configure Clp 1.13.1 on AIX. When I do not set CONFIG_SHELL=PATH/bash, the configure script of CoinUtils fails and terminates without writing configuration files, but the overall configuration still continues:

checking for COIN-OR package Sample... skipped check via pkg-config, redirect to fallback
checking for COIN-OR package Sample (fallback)... ./configure[34393]: projtoprocess=${projtoprocess/$proj/$projrequires}: bad substitution
configure: configuring in Osi

It appears that the offending part is around line 4225 in coin.m4:

      # add projrequires to the front of the list of projects that have to be processed next
      # at the same time, remove $proj from this list
      projtoprocess=${projtoprocess/$proj/$projrequires}

I don't know what this is supposed to do, so I cannot fix it. But I suggest to avoid any non-standard shell tools.

Thanks,

Andreas

Change History (3)

comment:1 Changed 8 years ago by stefan

  • Status changed from new to assigned

Hi,

it's supposed to substitute $proj by $projrequires in $projtoprocess.

I comitted a fix to BuildTools/trunk. Before rerunning autotools and merging around, can you test if it works on AIX now? E.g., use Osi/trunk and run the autotools on your checkout.

Stefan

comment:2 Changed 8 years ago by andreasw

Thanks, Stefan! This seems to have fixed it. I ran run_autotools on trunk and now the configuration went through.

Cheers,

Andreas

comment:3 Changed 8 years ago by stefan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in BuildTools/trunk, stable/0.6, and stable/0.7.
Reran autotools for projects in CoinAll/trunk and CoinAll/stable/1.5.
Can create new releases for projects in CoinAll 1.6 on request.

Stefan

Note: See TracTickets for help on using tickets.