Opened 12 years ago

Closed 12 years ago

#57 closed defect (worksforme)

Source and Binary Problems on Linux

Reported by: xiewg Owned by: andreasw
Priority: minor Component: configuration tests
Version: 0.5 Keywords:
Cc:

Description

  1. Binary executable requires libstdc++.so.6, which is not available. How can I get this dynamic library? I searched with no success.
  1. When following the instructions on compiling the source code, the last step: make install failed, with message: permission denied. Do we need administator to compile it?

Change History (3)

comment:1 Changed 12 years ago by xiewg

It is Clp.

comment:2 Changed 12 years ago by andreasw

  • Priority changed from major to minor
  • Status changed from new to assigned

Hi,

Regarding the first question, you would need to contact the people maintaining the COIN project for the distribution of binaries, see https://projects.coin-or.org/CoinBinary.

As for the second part, if you used the default settings for configure, in particular, if you didn't specify the --prefix flag, then the binaries are installed in subdirectories of the directory where you ran the configure command. This should not require any special privileges. However, if you specified another installation location, e.g., with --prefix=/usr/local, then you will need write permission for that location (which usually requires administrator privileges).

In case you didn't specify any --prefix flag for configure, please check in the output of make, for which command the error occurs, and see if that helps you to find out what is wrong. If the problem persists, please attach the output of "make install" and the config.log file to this ticket.

Andreas

comment:3 Changed 12 years ago by andreasw

  • Resolution set to worksforme
  • Status changed from assigned to closed

Nothing happened to ticket for 2 months. Closing.

Note: See TracTickets for help on using tickets.