Opened 12 years ago

Closed 12 years ago

#50 closed defect (worksforme)

ThirdParty/Mumps configure requires to have Mumps source code

Reported by: stefan Owned by: andreasw
Priority: minor Component: configuration tests
Version: 0.5 Keywords:
Cc:

Description

Hi,

my project has an external to ThirdParty/Mumps, so people who want to build Ipopt with Mumps can do it using the ThirdParty way. However, on some machines I want to build my own MUMPS library and provide it with the --with-mumps-dir flag. In this case, the configure-script in ThirdParty/Mumps is failing with the error

configure: error: cannot find sources (MUMPS/src/dmumps_part1.F) in ../../../GAMSlinks-trunk/ThirdParty/Mumps
configure: error: /bin/sh '../../../GAMSlinks-trunk/ThirdParty/Mumps/configure' failed for ThirdParty/Mumps

and the whole configure process is stopping.

I can avoid this by removing the ThirdParty/Mumps directory before running configure. However, this does not seem to be the elegant solution ;-).

Best, Stefan

Change History (1)

comment:1 Changed 12 years ago by andreasw

  • Resolution set to worksforme
  • Status changed from new to closed

Hi Stefan,

The problem is that you need to use

AC_COIN_THIRDPARTY_SUBDIRS([Mumps],[ThirdParty/Mumps],[MUMPS/src/dmumps_part1.F])

in your configure.ac file in your base directory, not

AC_COIN_THIRDPARTY_SUBDIRS([Mumps],[ThirdParty/Mumps],[configure.ac])
Note: See TracTickets for help on using tickets.