Opened 15 years ago

Closed 15 years ago

#5 closed defect (fixed)

building Cbc/examples on SunOS 5.8

Reported by: sdv Owned by: somebody
Priority: major Component: component1
Version: Keywords:
Cc:

Description

Hi,

trying to do the same (i tried before on my ibook) on a sun yields

CC -R/home/sungritzmann2/devries/Coin-Cbc/lib -O4 -DNDEBUG -o driver $bla -L/home/sungritzmann2/devries/Coi n-Cbc/lib -lCbc -lCgl -lOsiClp -lOsiCbc -lOsi -lClp -lCoinUtils -lm `cat /home/sungritzmann2/devries/Coin-Cbc/l ib/cgl_addlibs.txt cat /home/sungritzmann2/devries/Coin-Cbc/lib/osi_addlibs.txt cat /home/sungritzmann2/dev ries/Coin-Cbc/lib/clp_addlibs.txt cat /home/sungritzmann2/devries/Coin-Cbc/lib/coinutils_addlibs.txt` Undefined first referenced

symbol in file

void OsiClpSolverInterface::writeLp(FILE*,const double,const int,const int,const double,const bool)const CbcS olver2.o void OsiClpSolverInterface::writeLp(const char*,const char*,const double,const int,const int,const double,const

bool)const CbcSolver2.o

ld: fatal: Symbol referencing errors. No output written to driver gmake: * [driver] Error 1

after having issued a 'make' in Cbc/examples the errors above result...

best sven

Change History (1)

comment:1 Changed 15 years ago by andreasw

  • Resolution set to fixed
  • Status changed from new to closed

Sven found out that the problem was caused by an inconsistent use of the "const" attribute in the declaration and definition of writeLp. I now removed all unnecessary "const" attributes, and the declaration and definitions should be the same.

Note: See TracTickets for help on using tickets.