Opened 13 years ago

Closed 13 years ago

#25 closed defect (worksforme)

problem compiling Clp files downloaded from the coin-or library

Reported by: bcdandurand@… Owned by: somebody
Priority: major Component: component1
Version: Keywords:
Cc:

Description

I get the following error description when I run 'make' after having downloaded and configured the coin-or Clp library. Note that downloading and configuring went successfully. I am working on a Sun station. Below, I have pasted the compiling message followed by the configure.log contents. Let me know if you need anything else. Thank you.

Brian Dandurand

tutte% make Making all in CoinUtils? Making all in src Making all in Data/Netlib? Making all in Data/Sample? Making all in Clp Making all in src /bin/bash ../libtool --tag=CXX --mode=link CC -O4 -DNDEBUG -o clp -rpath /users/bdandur/coin-Clp/lib ClpMain?.o CbcOrClpParam?.o MyEventHandler?.o MyMessageHandler?.o unitTest.o libClp.la /users/bdandur/coin-Clp/Clp/?../CoinUtils?/src/libCoinUtils.la -lm cat /users/bdandur/coin-Clp/Clp/../CoinUtils/coinutils_addlibs.txt CC -O4 -DNDEBUG -o .libs/clp ClpMain?.o CbcOrClpParam?.o MyEventHandler?.o MyMessageHandler?.o unitTest.o ./.libs/libClp.so /users/bdandur/coin-Clp/Clp/?../CoinUtils?/src/.libs/libCoinUtils.so -lm -R/users/bdandur/coin-Clp/lib Undefined first referenced

symbol in file

std::basic_ostream<type_0,type_1>&std::operator<<<char,std::char_traits<char>,std::allocator<char> >(std::basic_ostream<type_0,type_1>&,const std::basic_string<type_0,type_1,type_2>&) ClpMain?.o void operator delete(void*,void*) ClpMain?.o unsigned std::string::length()const ClpMain?.o std::string::~basic_string() ClpMain?.o char*std::char_traits<char>::copy(char*,const char*,unsigned) unitTest.o void rwstd::string_ref<char,std::char_traits<char>,std::allocator<char> >::addReference() unitTest.o std::bad_alloc::bad_alloc() ClpMain?.o std::length_error::length_error(const std::string &) ./.libs/libClp.so rwstd::string_ref<char,std::char_traits<char>,std::allocator<char> >*std::string::pref()const unitTest.o std::vector<bool>::~vector() unitTest.o void std::string::unLink() ClpMain?.o void*operator new(unsigned,void*) ClpMain?.o const char*rwstd::except_msg_string::msgstr()const ClpMain?.o const char*std::string::c_str()const unitTest.o rwstd::null_string_ref_rep<char,std::char_traits<char>,std::allocator<char>,rwstd::string_ref_rep<std::allocator<char> > >::null_string_ref_rep() ClpMain?.o std::allocator<char>::allocator() ClpMain?.o std::basic_string<type_0,type_1,type_2>std::operator+<char,std::char_traits<char>,std::allocator<char> >(const std::basic_string<type_0,type_1,type_2>&,type_0) unitTest.o char*rwstd::string_ref<char,std::char_traits<char>,std::allocator<char> >::data()const unitTest.o rwstd::rw_basis<char*,std::allocator<char> >rwstd::rw_basis<char*,std::allocator<char> >::operator=(char*const&) unitTest.o char*rwstd::rw_basis<char*,std::allocator<char> >::data()const unitTest.o long rwstd::string_ref<char,std::char_traits<char>,std::allocator<char> >::references()const unitTest.o std::out_of_range::out_of_range(const std::string &) ClpMain?.o ld: fatal: Symbol referencing errors. No output written to .libs/clp * Error code 1 make: Fatal error: Command failed for target `clp' Current working directory /users/bdandur/coin-Clp/Clp?/src * Error code 1 make: Fatal error: Command failed for target `all-recursive' Current working directory /users/bdandur/coin-Clp/Clp? * Error code 1 make: Fatal error: Command failed for target `all-recursive'

configure.log contents:

This file contains any messages produced by compilers while running configure, to aid debugging if configure makes a mistake.

It was created by Clp configure 0.1, which was generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure

## --------- ## ## Platform. ## ## --------- ##

hostname = tutte.ces.clemson.edu uname -m = sun4u uname -r = 5.9 uname -s = SunOS uname -v = Generic_112233-06

/usr/bin/uname -p = sparc /bin/uname -X = System = SunOS Node = tutte.ces.clemson.edu Release = 5.9 KernelID = Generic_112233-06 Machine = sun4u BusType? = <unknown> Serial = <unknown> Users = <unknown> OEM# = 0 Origin# = 1 NumCPU = 1

/bin/arch = sun4 /usr/bin/arch -k = sun4u /usr/convex/getsysinfo = unknown hostinfo = unknown /bin/machine = unknown /usr/bin/oslevel = unknown /bin/universe = unknown

PATH: /bin PATH: /usr/bin PATH: /usr/ccs/bin PATH: /usr/etc PATH: /opt/SUNWspro/bin PATH: /usr/sbin PATH: /usr/ucb PATH: /usr/sfw/bin PATH: /usr/local/bin PATH: /usr/commercial/bin PATH: /usr/local/teTeX/bin PATH: /usr/openwin/bin PATH: /usr/java/bin PATH: . PATH: /usr/commercial/agilent/ads2005a/bin PATH: /usr/commercial/ansys_inc/v100/ansys/bin PATH: /usr/commercial/ESTECO/modeFRONTIER311/bin PATH: /usr/commercial/Fluent.Inc/bin PATH: /usr/commercial/ilog/bin PATH: /usr/commercial/wolfram/bin PATH: /usr/commercial/ricardo/bin PATH: /usr/commercial/ugs030/bin PATH: /usr/commercial/cgtech601/solaris/commands PATH: /usr/java/bin PATH: .

## ----------- ## ## Core tests. ## ## ----------- ##

configure:1294: checking for egrep configure:1304: result: egrep configure:1348: checking for a BSD-compatible install configure:1403: result: /usr/local/bin/install -c configure:1414: checking whether build environment is sane configure:1457: result: yes configure:1522: checking for gawk configure:1551: result: no configure:1522: checking for mawk configure:1551: result: no configure:1522: checking for nawk configure:1538: found /bin/nawk configure:1548: result: nawk configure:1558: checking whether make sets $(MAKE) configure:1578: result: yes configure:1748: checking whether to enable maintainer-specific portions of Makefiles configure:1757: result: no configure:2149: checking whether directory CoinUtils? is available configure:2164: result: yes configure:2187: checking whether directory Data/Netlib? is available configure:2202: result: yes configure:2225: checking whether directory Data/Sample? is available configure:2240: result: yes configure:2263: checking whether directory Clp is available configure:2278: result: yes configure:2455: creating ./config.status

## ---------------------- ## ## Running config.status. ## ## ---------------------- ##

This file was extended by Clp config.status 0.1, which was generated by GNU Autoconf 2.59. Invocation command line was

CONFIG_FILES = CONFIG_HEADERS = CONFIG_LINKS = CONFIG_COMMANDS = $ ./config.status

on tutte.ces.clemson.edu

config.status:669: creating Makefile configure:3320: configuring in CoinUtils? configure:3437: running /bin/bash './configure' --prefix=/users/bdandur/coin-Clp --cache-file=/dev/null --srcdir=. configure:3320: configuring in Data/Netlib? configure:3437: running /bin/bash './configure' --prefix=/users/bdandur/coin-Clp --cache-file=/dev/null --srcdir=. configure:3320: configuring in Data/Sample? configure:3437: running /bin/bash './configure' --prefix=/users/bdandur/coin-Clp --cache-file=/dev/null --srcdir=. configure:3320: configuring in Clp configure:3437: running /bin/bash './configure' --prefix=/users/bdandur/coin-Clp --cache-file=/dev/null --srcdir=. configure:3470: Main configuration of Clp successful

## ---------------- ## ## Cache variables. ## ## ---------------- ##

ac_cv_env_COIN_SKIP_PROJECTS_set= ac_cv_env_COIN_SKIP_PROJECTS_value= ac_cv_env_build_alias_set= ac_cv_env_build_alias_value= ac_cv_env_host_alias_set= ac_cv_env_host_alias_value= ac_cv_env_target_alias_set= ac_cv_env_target_alias_value= ac_cv_path_install=$'/usr/local/bin/install -c' ac_cv_prog_AWK=nawk ac_cv_prog_egrep=egrep ac_cv_prog_make_make_set=yes

## ----------------- ## ## Output variables. ## ## ----------------- ##

ACLOCAL='${SHELL} /users/bdandur/coin-Clp/missing --run aclocal-1.9' AMTAR='${SHELL} /users/bdandur/coin-Clp/missing --run tar' AUTOCONF='${SHELL} /users/bdandur/coin-Clp/missing --run autoconf' AUTOHEADER='${SHELL} /users/bdandur/coin-Clp/missing --run autoheader' AUTOMAKE='${SHELL} /users/bdandur/coin-Clp/missing --run automake-1.9' AUX_DIR= AWK='nawk' BUILDTOOLSDIR= COIN_SKIP_PROJECTS= CYGPATH_W='echo' DEFS='-DPACKAGE_NAME=\"Clp\" -DPACKAGE_TARNAME=\"clp\" -DPACKAGE_VERSION=\"0.1\" -DPACKAGE_STRING=\"Clp\ 0.1\" -DPACKAGE_BUGREPORT=\"coin-clp@…\" -DPACKAGE=\"clp\" -DVERSION=\"0.1\" ' ECHO_C= ECHO_N='-n' ECHO_T= EGREP='egrep' HAVE_EXTERNALS_FALSE= HAVE_EXTERNALS_TRUE='#' INSTALL_DATA='${INSTALL} -m 644' INSTALL_PROGRAM='${INSTALL}' INSTALL_SCRIPT='${INSTALL}' INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s' LIBOBJS= LIBS= LIBTOOLM4= LTLIBOBJS= MAINT='#' MAINTAINER_MODE_FALSE= MAINTAINER_MODE_TRUE='#' MAKEINFO='${SHELL} /users/bdandur/coin-Clp/missing --run makeinfo' PACKAGE='clp' PACKAGE_BUGREPORT='coin-clp@…' PACKAGE_NAME='Clp' PACKAGE_STRING='Clp 0.1' PACKAGE_TARNAME='clp' PACKAGE_VERSION='0.1' PATH_SEPARATOR=':' SET_MAKE= SHELL='/bin/bash' STRIP= VERSION='0.1' VPATH_DISTCLEANFILES= abs_bin_dir='/users/bdandur/coin-Clp/bin' abs_include_dir='/users/bdandur/coin-Clp/include' abs_lib_dir='/users/bdandur/coin-Clp/lib' abs_source_dir='/users/bdandur/coin-Clp' ac_ct_STRIP= amleading_dot='.' amtar='${AMTAR} chof - "$$tardir"' amuntar='${AMTAR} xf -' bindir='${exec_prefix}/bin' build_alias= datadir='${prefix}/share' exec_prefix='${prefix}' have_autoconf= have_automake= have_svn= host_alias= includedir='${prefix}/include' infodir='${prefix}/info' install_sh='/users/bdandur/coin-Clp/install-sh' libdir='${exec_prefix}/lib' libexecdir='${exec_prefix}/libexec' localstatedir='${prefix}/var' mandir='${prefix}/man' mkdir_p='$(install_sh) -d' oldincludedir='/usr/include' prefix='/users/bdandur/coin-Clp' program_transform_name='s,x,x,' sbindir='${exec_prefix}/sbin' sharedstatedir='${prefix}/com' subdirs=' CoinUtils? Data/Netlib? Data/Sample? Clp' sysconfdir='${prefix}/etc' target_alias=

## ----------- ## ## confdefs.h. ## ## ----------- ##

#define PACKAGE "clp" #define PACKAGE_BUGREPORT "coin-clp@…" #define PACKAGE_NAME "Clp" #define PACKAGE_STRING "Clp 0.1" #define PACKAGE_TARNAME "clp" #define PACKAGE_VERSION "0.1" #define VERSION "0.1"

configure: exit 0

Change History (3)

comment:1 Changed 13 years ago by andreasw

I (andreasw) am not sure that this is a BuildTools? issue. Will ask John Forrest to look at this.

comment:2 Changed 13 years ago by lou

Pulled down Clp/stable/1.3 and did vpath and non-vpath builds without error on Solaris 10 w/ Studio 11. Sent an email to Dandurand to see if it's still an issue.

comment:3 Changed 13 years ago by andreasw

  • Resolution set to worksforme
  • Status changed from new to closed

Brian sent email to Lou saying that it works on other SUNs he tried. Seems to be an issue with setup on one particular machine.

Note: See TracTickets for help on using tickets.