Opened 13 years ago

Closed 13 years ago

#23 closed defect (wontfix)

make distclean ignores COIN_SKIP_PROJECTS

Reported by: tkr Owned by: andreasw
Priority: minor Component: component1
Version: Keywords:
Cc: tkralphs@…

Description

If you skip a project in CoinAll? by setting the variable COIN_SKIP_PROJECTS and then try to make distclean afterwards, it tries to recursively make distclean in the skipped project directory anyway, which causes the command to fail.

Change History (3)

comment:1 Changed 13 years ago by andreasw

  • Cc tkralphs@… added
  • Owner changed from somebody to andreasw
  • Priority changed from major to minor
  • Status changed from new to assigned

I cannot reproduce this behavior. I justed checked out the trunk of BuildTools and and ran

./configure COIN_SKIP_PROJECTS='Alps Bonmin Dfo DyLP FlopCpp Ipopt multifario NLPAPI Smi SYMPHONY ThirdParty?/HSL Vol' --enable-static

After a 'make install' I typed 'make distclean' and it worked as advertised.

comment:2 Changed 13 years ago by tkr

OK, you might as well close this. I've switched to VPATH compilations, so it's irrelevant now anyway. I will let you know if I can reproduce it again.

comment:3 Changed 13 years ago by andreasw

  • Resolution set to wontfix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.