Opened 13 years ago

Closed 12 years ago

#2 closed enhancement (fixed)

Compiling with lapack and blas

Reported by: fmargot Owned by: andreasw
Priority: minor Component: component1
Version: Keywords: lapack
Cc:

Description

How do I compile a package with Lapack and Blas? With the old build process, there was a line

CoinLibsDefined += COIN_lapack

in Makefile.location. I tried

./configure --with-lapack --with-blas

but this does not seem to work. At least, there is no mention of Lapack or Blas in the config.log. I could not find any mention of this on the BuildTools? Trac pages.

Change History (5)

comment:1 Changed 13 years ago by andreasw

  • Owner changed from somebody to andreasw
  • Status changed from new to assigned

CoinUtils? has not yet been set up to work with Blas and Lapack. Will be addressed in the future.

comment:2 Changed 13 years ago by lou

In the macros COIN_HAS_BLAS and COIN_HAS_LAPACK, there is a subtle typo in the call to AC_COIN_TRY_FLINK for the *-sun-* case. Misplaced '],' means that sunperf isn't added to ADDLIBS. Here's a diff (line numbers are off because of some other local changes in my coin.m4).

@@ -2170,8 +2177,8 @@
       LIBS="-xlic_lib=sunperf $LIBS"
       AC_COIN_TRY_FLINK([daxpy],
                [AC_MSG_RESULT([yes])
-                use_blas='-xlic_lib=sunperf'],
-                ADDLIBS="-xlic_lib=sunperf $ADDLIBS"
+                use_blas='-xlic_lib=sunperf'
+                ADDLIBS="-xlic_lib=sunperf $ADDLIBS"],
                [AC_MSG_RESULT([no])
                 LIBS="$SAVE_LIBS"])
       ;;
@@ -2272,8 +2279,8 @@
         LIBS="-xlic_lib=sunperf $LIBS"
         AC_COIN_TRY_FLINK([dsyev],
                  [AC_MSG_RESULT([yes])
-                  use_lapack='-xlic_lib=sunperf'],
-                  ADDLIBS="-xlic_lib=sunperf $ADDLIBS"
+                  use_lapack='-xlic_lib=sunperf'
+                  ADDLIBS="-xlic_lib=sunperf $ADDLIBS"],
                  [AC_MSG_RESULT([no])
                   LIBS="$SAVE_LIBS"])
         ;;

comment:3 Changed 13 years ago by andreasw

  • Priority changed from major to minor

Corrected coin.m4 file in stable/0.5 and trunk, according to Lou's suggestion

I'm not closing ticket, since the Blas and Lapack libraries are still not properly integrated and documented.

comment:4 Changed 13 years ago by andreasw

Who voluntees to write the documentation...? :) It is all working properly now.

comment:5 Changed 12 years ago by andreasw

  • Resolution set to fixed
  • Status changed from assigned to closed

updated some documentation on the wiki. closing ticket.

Note: See TracTickets for help on using tickets.