Opened 13 years ago

Closed 13 years ago

#17 closed defect (fixed)

Fix detection of SYMPHONY by Osi

Reported by: tkr Owned by: andreasw
Priority: major Component: component1
Version: Keywords:
Cc:

Description

The presence of SYMPHONY is not properly detected by Osi, so that OsiSymSolverInterface? is not built, even when SYMPHONY is present.

Change History (4)

comment:1 Changed 13 years ago by andreasw

  • Owner changed from somebody to andreasw
  • Status changed from new to assigned

Ted, the issue is that the directory name is "SYMPHONY", but we use "Sym" as abbreviation in things like COIN_HAS_SYM etc. Do you prefer to use one single string for both (e.g., all SYMPHONY), or to use "SYMPHONY" for the directory name, and COIN_HAS_SYM as #define etc? I can do both - whichever you prefer.

comment:2 Changed 13 years ago by tkr

Andreas, I guess it makes sense to leave the directory name as it is and use the three-letter "Sym" everywhere else in order to conform to standard practice and be consistent with the Osi class name. However, it doesn't really matter that much.

comment:3 Changed 13 years ago by tkr

Andreas, I fixed this.

Ted

comment:4 Changed 13 years ago by andreasw

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.