Opened 6 months ago

Closed 8 weeks ago

#113 closed enhancement (migrated)

support for systems without pkg-config

Reported by: stefan Owned by: stefan
Priority: minor Component: build system
Version: trunk Keywords: autotools-update
Cc:

Description

Currently we rely on pkg-config being available. That seems to be common on Linux and Mac OS X. Also with MSys2 it is either already there by default or easy to install. So maybe we can assume its presence? If not, we could think about distributing an own replacement, e.g., from https://github.com/pkgconf/pkgconf

Change History (4)

comment:1 Changed 6 months ago by lou

I'm in favour of assuming pkgconf or pkg-config will be present, in the absence of a compelling example of a system we need to support that doesn't have it. If a compelling example comes up, I vote for distributing a replacement, but that gets us back to ThirdParty? software again. We definitely don't want to get back to reimplementing pkgconf in autotools macros.

comment:2 Changed 6 months ago by stefan

I'm in favor of this for the moment, too.

I had put this in here to cleanup another todo list, but used priority "minor" and type "enhancement" to indicate that this would rather be something far down the road.

comment:3 Changed 6 months ago by stefan

Input from Ted:

Pkg-config should be available on every system that we are supporting, but I see two issues. First is that pkg-config may often have to be installed manually, which adds complexity. I'm not sure if it comes by default on every Linux distro, but I don't think it comes by default on OS X (I could be wrong) and requiring users to get it via homebrew if that is the only reason they need to use homebrew might be a little nasty. On Windows, the problem is that there are multiple versions of pkg-config out there (windows paths versus posix) so things can get screwed up easily. We would have to experiment with what works well, but u think when building on Msys with Visual Studio, it may be impossible to get things right.

comment:4 Changed 8 weeks ago by stefan

  • Resolution set to migrated
  • Status changed from new to closed

Ticket has been migrated to GitHub and will be resolved there: https://github.com/coin-or-tools/BuildTools/issues/113

Note: See TracTickets for help on using tickets.