Changeset 4018


Ignore:
Timestamp:
Sep 17, 2019 4:46:49 AM (4 weeks ago)
Author:
stefan
Message:

update INSTALL instructions

  • similiar to r4004 in branch mumps5
File:
1 edited

Legend:

Unmodified
Added
Removed
  • ThirdParty/Mumps/branches/autotools-update/INSTALL.MUMPS

    r2747 r4018  
    1 Installation of the Mumps linear solver within COIN.
     1Installation of the Mumps linear solver within COIN-OR.
    22
    33Mumps is a MUltifrontal Massively Parallel sparse direct Solver.
     
    55Please visit the home page:
    66
    7 Home page: http://graal.ens-lyon.fr/MUMPS/
     7Home page: http://mumps.enseeiht.fr
    88
    99and make sure you read the conditions on distributing MUMPS
    10 in Chapter 11 of the MUMPS Users' Guide:
     10in Chapter 12 of the MUMPS Users' Guide:
    1111
    12 http://graal.ens-lyon.fr/MUMPS/doc/userguide_4.10.0.pdf
     12http://mumps.enseeiht.frdoc/userguide_4.10.0.pdf
     13
    1314
    1415**********************************************************************
     
    1718**********************************************************************
    1819
    19 If you are working under Unix/Linux-like system and you have `wget'
    20 installed, you can downloaded the required source code for MUMPS
    21 by executing the included script `get.Mumps' in this directory.
     20If you are working under Unix-like systems, you can downloaded the
     21required source code for MUMPS by executing the included script
     22`get.Mumps' in this directory.
    2223
    23 Note, however, that the script might not be looking for the most recent
    24 version of Mumps, and it might fail if it tries to download an outdated
    25 one.  In that case, please check the Mumps home page for the most recent
    26 version number and change the definition of the mumps_ver variable at the
    27 beginning of the get.Mumps script.
    28 
    29 If you don't have wget available, follow those instructions:
     24If using that script doesn't work for you, follow those instructions:
    3025
    3126Download Mumps 4.10:
    3227
    33 http://mumps.enseeiht.fr/MUMPS_4.10.0.tar.gz (or try
    34 http://graal.ens-lyon.fr/MUMPS/MUMPS_4.10.0.tar.gz if first URL doesn't work)
     28http://mumps.enseeiht.fr/MUMPS_4.10.0.tar.gz
    3529
    3630and unpack it in this directory:
     
    4337mv MUMPS_4.10.0 MUMPS
    4438
    45 Finally, apply a small patch to work around a bug in MUMPS:
     39Finally, apply some changes to improve MPI compatibility of MUMPS and
     40work around a bug in MUMPS:
    4641
    4742patch -p0 < mumps.patch
     43patch -p0 < mumps_mpi.patch
     44mv MUMPS/libseq/mpi.h MUMPS/libseq/mumps_mpi.h
Note: See TracChangeset for help on using the changeset viewer.