Changeset 2861 for trunk/coin.m4


Ignore:
Timestamp:
Aug 23, 2013 8:39:51 PM (6 years ago)
Author:
tkr
Message:

Quoting PKG_CONFIG and setting CYGPATH_W to echo for gcc

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/coin.m4

    r2801 r2861  
    381381      AC_MSG_NOTICE([Overruling autoconf; cl does not recognise -g.])
    382382    fi ;;
     383  * )
     384    CYGPATH_W = echo
     385    ;;
    383386esac
    384387CXXFLAGS="$save_cxxflags"
     
    874877  cl* | */cl* | CL* | */CL* | icl* | */icl* | ICL* | */ICL*)
    875878    coin_cc_is_cl=true
     879    ;;
     880  * )
     881    CYGPATH_W=echo
    876882    ;;
    877883esac
     
    32163222    _pkg_min_version=m4_default([$1], [0.16.0])
    32173223    AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
    3218     if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
     3224    if "$PKG_CONFIG" --atleast-pkgconfig-version $_pkg_min_version; then
    32193225      AC_MSG_RESULT([yes])
    32203226    else
     
    32263232  # check if pkg-config supports the short-errors flag
    32273233  if test -n "$PKG_CONFIG" && \
    3228     $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
     3234    "$PKG_CONFIG" --atleast-pkgconfig-version 0.20; then
    32293235    pkg_short_errors=" --short-errors "
    32303236  else
     
    33093315[AC_REQUIRE([AC_COIN_HAS_PKGCONFIG])
    33103316if test -n "$PKG_CONFIG" ; then
    3311   if $PKG_CONFIG --exists "m4_tolower($1)"; then
    3312     m4_toupper($1)[]_VERSION=`$PKG_CONFIG --modversion "m4_tolower($1)" 2>/dev/null`
     3317  if "$PKG_CONFIG" --exists "m4_tolower($1)"; then
     3318    m4_toupper($1)[]_VERSION=`"$PKG_CONFIG" --modversion "m4_tolower($1)" 2>/dev/null`
    33133319    m4_ifval([$2], [$2], [:])
    33143320  else
    3315     m4_toupper($1)_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "m4_tolower($1)"`
     3321    m4_toupper($1)_PKG_ERRORS=`"$PKG_CONFIG" $pkg_short_errors --errors-to-stdout --print-errors "m4_tolower($1)"`
    33163322    $3
    33173323  fi
     
    33333339[AC_REQUIRE([AC_COIN_HAS_PKGCONFIG])
    33343340if test -n "$PKG_CONFIG" ; then
    3335   if $PKG_CONFIG --exists "$2"; then
    3336     m4_toupper($1)[]_VERSIONS=`$PKG_CONFIG --modversion "$2" 2>/dev/null | tr '\n' ' '`
     3341  if "$PKG_CONFIG" --exists "$2"; then
     3342    m4_toupper($1)[]_VERSIONS=`"$PKG_CONFIG" --modversion "$2" 2>/dev/null | tr '\n' ' '`
    33373343    $3
    33383344  else
    3339     m4_toupper($1)_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "$2"`
     3345    m4_toupper($1)_PKG_ERRORS=`"$PKG_CONFIG" $pkg_short_errors --errors-to-stdout --print-errors "$2"`
    33403346    $4
    33413347  fi
     
    33613367
    33623368AC_COIN_PKG_CHECK_MODULE_EXISTS([$1],[$2],
    3363   [ cflags=`$PKG_CONFIG --cflags "$2" 2>/dev/null`
     3369  [ cflags=`"$PKG_CONFIG" --cflags "$2" 2>/dev/null`
    33643370    # pkg-config cannot handle spaces, so CYGPATH_W cannot be put into .pc files
    33653371        # thus, we modify the cflags extracted from pkg-config by putting CYGPATH_W behind -I's
     
    33703376    fi
    33713377    m4_toupper($1)[]_CFLAGS="$cflags"
    3372     m4_toupper($1)[]_LIBS=`$PKG_CONFIG --libs "$2" 2>/dev/null`
    3373     m4_toupper($1)[]_DATA=`$PKG_CONFIG --variable=datadir "$2" 2>/dev/null`
     3378    m4_toupper($1)[]_LIBS=`"$PKG_CONFIG" --libs "$2" 2>/dev/null`
     3379    m4_toupper($1)[]_DATA=`"$PKG_CONFIG" --variable=datadir "$2" 2>/dev/null`
    33743380    $3
    33753381  ],
Note: See TracChangeset for help on using the changeset viewer.