Changeset 2319


Ignore:
Timestamp:
Jun 19, 2011 10:47:23 AM (8 years ago)
Author:
stefan
Message:

no check for coinmetis version number for now

Location:
ThirdParty/Mumps/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • ThirdParty/Mumps/trunk/configure

    r2300 r2319  
    2539525395
    2539625396if test -n "$PKG_CONFIG" ; then
    25397   if $PKG_CONFIG --exists "coinmetis >= 4.0"; then
    25398     METIS_VERSIONS="`$PKG_CONFIG --modversion "coinmetis >= 4.0" 2>/dev/null | sed -n -e "1h;2,\\$H;\\${g;s/\n/ /g;p}"`"
    25399      cflags=`$PKG_CONFIG --cflags "coinmetis >= 4.0" 2>/dev/null`
     25397  if $PKG_CONFIG --exists "coinmetis"; then
     25398    METIS_VERSIONS="`$PKG_CONFIG --modversion "coinmetis" 2>/dev/null | sed -n -e "1h;2,\\$H;\\${g;s/\n/ /g;p}"`"
     25399     cflags=`$PKG_CONFIG --cflags "coinmetis" 2>/dev/null`
    2540025400    # pkg-config cannot handle spaces, so CYGPATH_W cannot be put into .pc files
    2540125401        # thus, we modify the cflags extracted from pkg-config by putting CYGPATH_W behind -I's
     
    2540625406    fi
    2540725407    METIS_CFLAGS="$cflags"
    25408     METIS_LIBS=`$PKG_CONFIG --libs "coinmetis >= 4.0" 2>/dev/null`
    25409     METIS_DATA=`$PKG_CONFIG --variable=datadir "coinmetis >= 4.0" 2>/dev/null`
     25408    METIS_LIBS=`$PKG_CONFIG --libs "coinmetis" 2>/dev/null`
     25409    METIS_DATA=`$PKG_CONFIG --variable=datadir "coinmetis" 2>/dev/null`
    2541025410     coin_has_metis=yes
    2541125411        echo "$as_me:$LINENO: result: yes: $METIS_VERSIONS" >&5
     
    2541825418          METIS_LIBS=`echo " $METIS_LIBS " | sed -e 's/ \(\/[^ ]*\/\)\([^ ]*\)\.lib / \`$(CYGPATH_W) \1 | sed -e "s|\\\\\\\\\\\\\\\\\\\\|\/|g"\`\2.lib /g'`
    2541925419        fi
    25420         METIS_PCREQUIRES="coinmetis >= 4.0"
     25420        METIS_PCREQUIRES="coinmetis"
    2542125421
    2542225422        # augment X_PCREQUIRES, X_CFLAGS, and X_LIBS for each build target X in MUMPS
    2542325423
    25424           MUMPS_PCREQUIRES="coinmetis >= 4.0 $MUMPS_PCREQUIRES"
     25424          MUMPS_PCREQUIRES="coinmetis $MUMPS_PCREQUIRES"
    2542525425          MUMPS_CFLAGS="$METIS_CFLAGS $MUMPS_CFLAGS"
    2542625426          MUMPS_LIBS="$METIS_LIBS $MUMPS_LIBS"
     
    2542925429
    2543025430  else
    25431     METIS_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "coinmetis >= 4.0"`
     25431    METIS_PKG_ERRORS=`$PKG_CONFIG $pkg_short_errors --errors-to-stdout --print-errors "coinmetis"`
    2543225432      coin_has_metis=notGiven
    2543325433        echo "$as_me:$LINENO: result: not given: $METIS_PKG_ERRORS" >&5
     
    2546525465METIS_PCREQUIRES=
    2546625466
    25467 # initial list of dependencies is "coinmetis >= 4.0", but we need to filter out version number specifications (= x, <= x, >= x, != x)
    25468 projtoprocess="coinmetis "
     25467# initial list of dependencies is "coinmetis", but we need to filter out version number specifications (= x, <= x, >= x, != x)
     25468projtoprocess="coinmetis"
    2546925469
    2547025470# we first expand the list of projects to process by adding all dependencies just behind the project which depends on it
     
    2566725667  fi
    2566825668
    25669   METIS_PCREQUIRES="coinmetis >= 4.0"
    25670 
    25671     MUMPS_PCREQUIRES="coinmetis >= 4.0 $MUMPS_PCREQUIRES"
     25669  METIS_PCREQUIRES="coinmetis"
     25670
     25671    MUMPS_PCREQUIRES="coinmetis $MUMPS_PCREQUIRES"
    2567225672    MUMPS_CFLAGS="$METIS_CFLAGS $MUMPS_CFLAGS"
    2567325673    MUMPS_LIBS="$METIS_LIBS $MUMPS_LIBS"
  • ThirdParty/Mumps/trunk/configure.ac

    r2023 r2319  
    9797
    9898AC_COIN_CHECK_PACKAGE_BLAS(MUMPS)
    99 AC_COIN_CHECK_PACKAGE(Metis, [coinmetis >= 4.0], MUMPS)
     99AC_COIN_CHECK_PACKAGE(Metis, [coinmetis], MUMPS)
    100100
    101101if test "$coin_has_metis" = yes; then
Note: See TracChangeset for help on using the changeset viewer.